O seu servidor funciona com a versão 5.2.0 do PHP, mas o WordPress 4.0.1 necessita pelo menos da versão 5.2.4.